app在线制作|网站生成app

注册
最新资讯
最新资讯 > “App开发者需要更新此App以在此iOS版本上正常工作 ” 解决方法

“App开发者需要更新此App以在此iOS版本上正常工作 ” 解决方法

文章发布时间:2021-06-30 15:48:41
   

最近随着iOS隐私协议更新以及iOS14.6系统正式放开,很多已经安装的app在升级到iOS14.6或者iOS15之后在打开App时都会提示“App开发者需要更新此App以在此iOS版本上正常工作 ”,而无法正常使用!此提示是因苹果正版签名(CodeSign)更新所致,导致所有之前macOS11以下系统打包的App在iOS14.6或者iOS15以上的设备会都提示需要更新才能正常工作。

开发者需要更新App


解决方法:

首先打包环境 mac升级到macOS11以上,此时打包会采用新的签名机制!在升级到最新系统之后,重新通过Xcode打包生成新的安装包即可!对于企业签的App,则需要企业签名提供商签名mac环境同样升级到macOS11系统之上重新签名方可解决。

上一篇:暂无

下一篇:小鸡模拟器ios版安装地址,小鸡模拟器在线安装

回到顶部